#SL Pyramid Warning Symbols

Recently a number of us have been seeing a flock of organdy-yellow pyramids appear around us when trying on mesh. They look very much like the script warnings we see when a script fails. However, they are a little different in that they do not have the little piece of paper denoting a script within the icon.

These non-script inspired pyramids are caused by mesh failing to rez. It is unclear whether this is solely a viewer issue or a viewer and server issue. Whatever the case, the quick fix is a relog or teleport to another region.

One can also change the viewer settings to reduce the likelihood of being a roosting perch for a flock of pyramids. The setting can only be founds in the Debug Settings.

This is hard to test so I’m doing some speculation on whether or not the change is worth the effort.

MeshMaxConcurrentRequests – Number of threads to use for loading meshes. Default value 32. It is probably better to reduce this setting if you have a slower connection. Try increasing it if you hang out in places like TRUTH Hair. I know at least one person setting this at 256 and claiming it cured the problem. I’m not convinced.

I suggest leaving it at 32 unless you have a significant and persistent problem. If you do decide to change it, try 16 or 64.

I can’t find any other settings that limit mesh render. I seem to remember there were more. But, they have disappeared from recent viewers. So, there is little we can do to avoid the problem.

3 thoughts on “#SL Pyramid Warning Symbols

  1. Thanks for this, Nalates. I had this ‘pyramid swarm’ problem with one mesh hair demo from Truth and for the life of me I couldn’t figure out what was going on, apart from the fact that only the front of the hair was rezzing. I assumed it was a problem with the demo itself, not my viewer, as the other demos I’d picked up were fine.

    • I ran into the exact same thing with the Amelia do. I was wondering what’s with all the script errors. I skipped buying it thinking something was wrong with the hair. I tried the demo again at home and it worked fine. I went back and bought it. Only later did I find out what the problem was.

      • Yes, it was the Amelia style for me as well. I wonder if Truth Hawks noticed not many people buying that, because they tried the demo in the store and thought there was something wrong with it?

        Hrm. I also wonder if it was server-specific. I tried the demo in two different regions and encountered the problem in both (as well as in the Truth store itself), but on checking back both of those regions were on the Le Tigre server channel. I might try the same demo on Magnum and BlueSteel to see if the same issue crops up there. I’m not sure which channel the Truth region is on; be interesting to see of that’s Le Tigre as well.

Leave a Reply to Mariel Tigerpaw Cancel reply

Your email address will not be published. Required fields are marked *