#SL Clouds, Grey, and Blurry Avatars

We seem to be getting another round of poorly rezzing avatars. The particle cloud avatars we know about. That is often a connection issue. I write my fix-it article Avatar Render Problems: Ghost Cloud Smoke Ball Ruth in September 2010. But, something new is up.

The Problem - Extended Bake Fail

Blurry Avatars

For several weeks I have noticed when changing clothes I get a blurry avatar. My skin and clothes start blurry after a change, then rez nice and crisp once, then go blurry again and never seem to finish rezzing.  They stay blurry.

This is a type of bake-fail. But, no matter how many times I press Ctrl-Alt-R to re-bake the clothes stay blurry. I can see the initial bake go crisp and sharp. Then as the composite uploads and downloads something hangs and I never get my nice crisp bake back.

Aside: If you don’I know about the bake pipeline for avatars, read on otherwise skip this.

Your viewer downloads all the textures needed to make your avatar. If any of those downloads fails you remain a particle ball. Once all the textures are downloaded the viewer makes a single composite image from the collection. This process is called a bake. At the end of it you see your avatar fully render all crisp and sharp. Then the viewer uploads the composite image for everyone to use for your avatar. That saves them downloading all the textures and baking their own for you. For whatever reason, your viewer downloads a copy of the composite too. It then uses that copy for you to see in your viewer. When you remain blurry something went wrong with the upload or down load.

I’m not the only one running into this problem. My friends have been asking me about the problem. And the Lindens have asked for help solving the problem. There are a couple of ways to work around the problem. Change your group tag or group. Even the Lindens do not know why this works, but the fix has been around since before I came to Second Life.

The other fix is to move to another region and re-bake. Sometimes just moving to a new region fixes the problem. But, you usually have to re-bake.

Fixing the Problem

The Lindens are having some challenges tracking down the problem. So, they have made a viewer with more debugging code that adds more information to the log file. If you are willing to help track the problem down, you can get a copy of the project viewer and help. Of course you have to have the problem to help. If you aren’t seeing the problem… you’re no help. :p

What is needed is for you to use the viewer and experience the problem. This will get the information into the log. Once you have experienced the problem, preferably more than once, close the viewer. Drill into the Roaming folders and rename the log. The next time you start the viewer, it will overwrite the previous log.

With that information, file a JIRA with a copy of the log attached.

If you are willing to do that, get a copy of the Runway Project Viewer by Vir Linden. If that page shows a build in progress, get the Previous Good Build. (3.3.0-250307 in my case).

Summary

There is rumor but no confirmation that a new avatar bake pipeline is being developed. I forget which, but one of the Lindens was describing some of the complexity of the avatar render pipeline. There is so much complexity they are having trouble finding where the current process is hanging.

One could guess that the problem will extend to the new pipeline, if the problem is in one of the supporting subsystems. Since the avatar pipeline depends on so many other parts of the SL system and they cannot all be re-written, finding where the problem is becomes an important early step.

5 thoughts on “#SL Clouds, Grey, and Blurry Avatars

  1. Pingback: Why Do I Have to Constantly Rebake in SL? - SLUniverse Forums

  2. Pingback: Second Life Changes Coming

  3. Pingback: #SL Avatar Render & Bake Fail

  4. I may have something to help you track down the problem.

    Under Develop>rendering> I turned on full Res Textures.

    The blur went away with first rebake and hasn’t come back since. Could the issue possibly be some kind of texture compression to save on data transfer?

    I’ve noticed that I do have to rebake when I change clothes for it to take effect. This might also be bi-passing the composite image. I’m sorry I can’t narrow down the code more I just noticed it as a fix for the problem.

    • According to Nyx Linden the problem is a basic flaw in the idea of how the avatar bake was implemented. The process is being revamped to eliminate the collection of problems.

      This article is an old one and many things have changed. We expect the new system to be in place by the end of March.

Leave a Reply to Misfit Cancel reply

Your email address will not be published.