Second Life Materials Bugs

I’m enjoying the new Materials enabled SL Viewer. But, some people are running into problems. Here is what’s coming up:

Whirly's Example - Notice the red colored area.

Whirly’s Example – Notice the red colored area.

MATBUG-171Shiny objects or objects with reflections look shiny white. Description: When I activate the Advanced Lighting model in the viewer for the materials features, all shiny objects and objects appear shiny white as if glow was very high. — ATI Radeon HD 4870 OpenGL Engine 2.1 ATI-1.6.36 

MATBUG-197Streaky glowing water with ALM enabled. Description: Enabling Advanced Lighting Model causes glowing streaks in water. They are visible with the sun position at sunset or sunrise and not at midday or midnight. — NVIDIA GeForce 8600M GT OpenGL Engine 2.1 NVIDIA-1.6.36

MATBUG-216White artifacts when advanced lighting is enabled. Description: When I activate advanced lighting feature in the material viewer, I get a lot of white glowing points on some objects around me. — ATI Radeon HD 4870 OpenGL Engine 2.1 ATI-1.6.36.

I am using GeForce GTX 560 Ti/PCIe/SSE2 OpenGL Version: 4.2.0. I’m not seeing these problems. Form these 3 reports it seems there is an issue between the OpenGL 2.1 driver and SL…

If you are seeing white streaks with the Advanced Lighting Model (ALM) enabled, check your OpenGL version and consider an update. If that does NOT fix the problem, please file a JIRA and refer to these reports.

MATBUG Project Stats 2013-26 - June 26

MATBUG Project Stats 2013-26 – June 26

Some other problems being seen:

MATBUG-226Transparent/Alphas Appear Black w/ Glow Under Advanced Lighting. Description: When advanced lighting is checked, items throughout the area with a transparent texture or an normal texture but with transparency set though the edit window and with glow enabled turn solid opaque. This does not effect [sic] transparent items or alphas that do not have any glow set. — GeForce GT 335M/PCIe/SSE2 OpenGL Version: 3.3.0 – Work-around: Setting glow to 0. See: MATBUG-175.

MATBUG-230Viewer Performance Issues on Retina MacBook Pro. — NVIDIA GeForce GT 650M OpenGL Engine 2.1 NVIDIA-8.12.47 310.40.00.05f01.

MATBUG-233Every time a system layer or prim is worn, all prims fall off. Description: I was swapping pieces on my avatar and when I put one thing on, all prims fell off including HUDs. I have tested all layers. — GeForce GTX 550 Ti/PCIe/SSE2 OpenGL Version: 4.2.0

Summary

I would guess the issues between SL and OpenGL 2.1 are the root of a number of rendering issues. For a fix a simple video driver update might do the trick.

Leave a Reply

Your email address will not be published.