Pink Prims Bug

A number of people updating to SL Viewer 3.2.8 are getting pink prims. See the image below.

Image by Blaise Glendevon

There are two fixes. Neither are that great, but they will get you by until the Lab brings out a fix. The fix is thanks to the Firestorm/Phoenix Team, as far as I can tell. See: FIRE-4945 – Pink/Fushia textures when basic shaders enabled on ATI 3000-4000-5000 series cards.

Whirley Fizzle in the JIRA writes:

  • Paste in all your system information from Help -> About Firestorm so we can see your graphics card & driver version
  • *Fast “Fix”:
    • Bring up the Advanced top menu with CTRL+ALT+D
      Then Advanced -> Debug settings -> RenderMaxTextureIndex -> Set this to zero
      This should fix the pink textures but may also cause a drop in your FPS (Frames per second)
    • Disabling Basic Shaders (Avatar -> Preferences -> Graphics -> General -> Advanced -> Basic shaders) will also stop the pink, but things will not look as pretty.
  • Open Stats window with CTRL+SHIFT+1
    Look at your FPS at the top of that window. Do you see a drop when you toggle RenderMaxTextureIndex betwen its default value (16) and zero?

You can find instructions on how to find your SL logs for viewer 3 here: http://wiki.secondlife.com/wiki/Debug_Help

Info from Runitai Linden: RenderMaxTextureIndex controls how many textures can be combined into a single batch, so setting it to 0 will effectively give you 50% more draw calls. On systems where draw call overhead is the bottleneck, this can result in a huge performance penalty.

Summing Up

I’ve seen people complaining about the problem in the SL Forum and SL Answers. Most are new to SL and don’t know to post the contents of the viewer’s Help->About… when asking for help. So, its not possible for me to know whether this is an ATI/AMD only problem or not. But, it appears it is.

The Lab is working on a fix.

Peeps are discussing the problem on SL Universe: V3 Bug – Help, Please!

There is no truth to the rumor that this is the first phase of an attempt by Torley Linden to take over the world… er… Second Life.

2 thoughts on “Pink Prims Bug

  1. Pingback: Nirans Viewer Release 1.33 Review

  2. I notice this blogpost is old, however I experienced this issue today (yeah, I’m slow at updating) on my Nvidia 9600GT, so I can confirm it’s not only limited to ATI hardware.

    Initially I fixed this bug by deleting C:\Users\\Roaming\\user_settings\settings.xml, the viewer creates a new, working settings.xml during loading, but it will reset all Preferences to their defaults.

    Upon closer inspection, the Debug Setting ‘RenderGLCoreProfile’ being set to TRUE is what caused it. Setting it to FALSE (which is, I believe, the default) resolved the issue after a relog.

    I hope this information is useful.

Leave a Reply

Your email address will not be published. Required fields are marked *